IE8 Slow Opening New Tab/Window

I have had a problem ofver the last few weeks with IE8 (running on the Windows 7 RC). Suddenly, any time I opened a new tab or new window (including initial startup, opening a blank tab, or openig a link in a new tab or window) became extremely slow. I am talking 10-30 seconds just to open a blank tab. It would sit there saying “Connecting”. What the heck is a blank tab connecting to for 30 seconds????

Finally, this morning, I got irritated enough to look for a solution.

After a little digging on the web, I found several references to similar problems which seemed to be related to particular browser add-ons. Unfortunately, I do not have any of the add-ons from any of the discussions I found. It did seem to indicate an add-on could be the problem, however. So, I decided to just work through it the hard way – by trial and error. I opened the IE8 add-on manager (Tools | Manage Add-ons) and disabled all of the add-ons listed. I closed the dialog and created a new tab – and voila, opened in under a second. I then closed the browser and re-launched it. All of my tabs opened almost instantly.

So now I just had to figure out which of the add-ons was causing the problem. Fortunately, I do not have many add-ons:

Add-ons List
Add-ons List

As it turns out, as soon as I enabled the first one on the list (Java plugin helper), the slowness returned. Just for good measure, I went through and enabled each of the other add-ons individually, and none of the them caused any performance change.

So, now the Java plugin helper is disabled, all the others enabled, and all is good. When I get around to it, I will look and see if there is a fix for this plugin.

Makes me wonder, though, how something as fundamental as the Java plugin could be causing this problem, with no one screaming about it. Is it just me?

Advertisement
%d bloggers like this: